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Lesson 6: Work in Multi-Model Environment 
with Surface

Case Study: Multi-Model Environment with Surface
Design Intent
Stages in the Process
Surface and Wireframe Publication
Use Published Surface in Product Context

In this lesson, you will learn how to work in Multi-Model Environment with 
Surface.

Lesson Contents:

Duration: Approximately 2 Hours
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Case Study: Multi-Model Environment with Surface

The case study for this lesson is to create a ‘Web Camera’. The focus of this case study is to create a 
model in multi-model environment using the Publication tool, in assembly context. Your goal is to establish 
link between two parts containing variants of the same part. The focus of the case study in this lesson is to 
understand, how the tool helps to manage the iterations in a product development cycle.
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Design Intent

� Built the top part using bottom half of the camera without 
using Publication.
� Use the existing surfaces of reference part without 

publishing.
� Replace the bottom (referenced part) by its variant part, 

which has a different shape.
� Updating the model with new variant will not be possible with 

out re-routing the child features.
� You will have to re-route the features. Note the changes. 
Close the assembly without saving.

� Publish the required surfaces of reference bottom half of the 
camera case.

� Build the top part again using the published surfaces.
� Replace the bottom (referenced part) by its variant part.

• Ensure that the variant part has similar set of published 
elements and has the same nomenclature.

� Update the model. You will be able to update without any re-
routing.

The intent of the case study is to build multi-model links between parts using the Publication tool. This 
would help in managing design iterations during product development cycle and provides easy availability 
of geometric elements to different users.

Inferior body 
(Bottom half)

Top Part       
(To be built)
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Stages in the Process

The following steps are to be used to perform the case study:

1. Build the Top part referring to the Inferior body without using Publication.

2. Replace the Inferior body with its variant and update the assembly. You will have to 
re-route links.

3. Publish the reference part.

4. Rebuild the top part using published elements.

5. Now replace Inferior body with its variant (with published element) and update the 
assembly. Assembly gets updated without manual re-routing.
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Step 1 : Surface and Wireframe Publication

In this section, you will learn about Publication 
and how surfaces and wireframes are published.

Use the following steps:

1. Surface and Wireframe 
Publication

2. Using Published Surface in 
Product Context
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Why Publish Geometry?

Publishing geometry has many benefits such as:

A. Label a geometry to give it a name that can be easily 
recognized (particularly in the case of publishing edges, 
faces, etc.). 

B. To make a particular geometry easier to access from 
the specification tree.

C. Control external references. An option is available that 
allows you to select, as an external reference, only the 
published elements.

D. Easy replacement of one feature of the part with 
another. Published elements that have same name in 
the source part and the child part are automatically 
reconnected. You would have to reconnect them all one 
by one if they are not published. 

Mouse

Lower Assy

Front Left Assy

Button Assy

Cover

A_Surfaces

Surfaces

Multi-Section Surface

Publication

Sweep

Sweep

Blend

B_Surfaces

Reference Surface

Lower Surface

Upper Surface

Side Surface

A

B

D

Let us see these advantages
(L6_PUBLICATION.CATProduct)
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When to Publish Wireframes and Surfaces?

Benefits of PublicationElements to be PublishedIterations of the Inputs 
geometries

.

.

.

1. Reference Geometries.

2. Elements subjected to 
regular iterations.

3. Geometries commonly 
referred by different users.

1. Multiple user can refer the 
published feature and 
design the family parts.

2. Modifications in the parent 
published part are 
propagated to linked part 
without manual re-routing.

In a Concurrent engineering context: 
Use style input data bound to be versioned (style iteration)
Style input is mainly composed of wires and surfaces

Wires and surfaces publication is important in a concurrent engineering context.
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Geometry Publication

Wires and surfaces involved in a concurrent engineering process 
are published at the part level:

The part containing the geometry to 
publish is activated

The publication appears in the tree

Let us see the geometry publication
(L6_PUBLICATION.CATProduct)
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Publishing Geometry at a Part Level

1

4

2

Use the following steps to publish elements:
1. In the context of an assembly, activate the part 

containing the geometry to be published 
(double-click).

2. Select the elements to be published (multi-
selection is possible).

3. Select Tools >Publication.
4. In the Publication dialog box, enter the 

publication names. Validate by clicking OK.

Observation: The published elements appear in the 
tree with their publication names.

Published Elements
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Step 2: Use Published Surface in Product Context

In this section, you will learn about Publication 
and how surfaces and wireframes are published.

Use the following steps :

1. Surface and Wireframe 
Publication

2. Using Published Surface 
in Product Context
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Use Published Elements in Multi-Model Link (1/2)

There are two methods to use published geometry of a 
part in a multi-model environment.

A. Geometry Selection during design process.

B. Copy/Paste published elements.

Let us understand this with an example,

A. Geometry Selection during design process:

1. Publishing of Elements
2. Creating External References in a New part
3. Creating parametric surface using external 

referenced geometry

Contextual Link

Pu
bl

is
he

d

Import Link

1

2

3
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Use Published Elements in Multi-Model Link (2/2)

B. Copy/Paste of published elements:

You can also copy/paste the published 
elements with links, to place the external 
references in “New Part” before you need 
them. The result is the same even in the tree.
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Published versus Unpublished Surface

Let us see the difference in the behavior on Copy/Pasting a link with a published surface and with 
an unpublished surface from one part to another.

Let us compare the two behaviors
(L6_PUBLICATION.CATProduct)

Action                 Behavior in a Unpublished 
Surface

Does not support the replacement of 
the surfaces or feature.

When the source 
surface is replaced by 
new surface or feature

A warning is displayed conveying the 
missing of source surface

The modification is propagated to the 
target part surface

When a surface is 
modified in the source 
part

Behavior in a Published Surface

The surface get isolated automatically

The modification is propagated to the 
target part surface

Upon updating, the child surface 
synchronizes with the new parent.

When the surface is 
deleted in the source file
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To Sum Up

In the following slides you will find a summary of the topics covered in this lesson.
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Publication helps in managing design iterations during 
product development cycle and provides easy 
availability of geometric elements to different users. 
Wires and surfaces are published at part level. 
Following points must be kept in mind:

� The name of the published element must be 
exactly similar to that in source part and child 
part.

� Easily recognizable names must be given to the 
published elements.

� Geometry is grouped to give easier access in the 
Specification Tree.

� An option is available that allows to select, only 
the published elements as an external reference.

Surface and Wireframe Publication
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1. Geometry Selection during design process.
A. Publishing of Elements.
B. Creating External References in a New 

part.
C. Creating parametric surface using external 

referenced geometry.
2. Copy/Paste published elements: You can also 

copy/paste the published elements with links, 
to place the external references in “New Part”
before you need them. The result is the same 
even in the tree.

There are two methods to use published geometry 
of a part in a multi-model environment.

2

Contextual Link

Pu
bl

is
he

d

Import Link

1

A

B

C

Use Published Surface in Product Context
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Exercise 6A
Recap Exercise

20 min

In this exercise you will  build a model in a Multi-Model Environment. You will create 
a model for Appliance Knob using external references. Detailed instruction for this 
exercise is provided.
By the end of this exercise you will be able to:

� Create a copy/paste special of one part to another using different 
options.

� Create a multi-model link between the parts.
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Exercise 6A (1/4)

1. Open the Target file.
� Open the target file of the Knob consisting of the 

stem features of the knob.
a. Click File > open.
b. Browse and select the Part- Exercise_6A_target.
c. Click Open.

2. Open the Source file.
� Open the source file of the Knob consisting of the 

outer surfaces.
a. Click File > open.
b. Browse and select the Part- Exercise_6A_ Source
c. Click Open.

Target Part

Stem

Source Part

Knob Surface

11

2
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Exercise 6A (2/4)

3. Copy the final surface of the knob from Source part.
� Copy the surface Edgefillet.3 from the specification  

tree of the source part .
a. Right-click on Edgefillet.3
b. Select Copy to copy the surface.

4. Paste Special the copied surface into the target file.
� Paste special the surface Edgefillet.3 into the 

target part as shown.
a. Paste Special –as a result with link
b. Click OK

� You will observe that a geometrical set named 
‘External Reference’ is created and the surface linking 
to source part is pasted into it.

3a

3b

4a

4b
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Exercise 6A (3/4)

5. In the Part Design workbench, Split the solid body 
using the external referenced surface.

� Split the solid using knob surface.
a. Select Insert > Surface-Based Feature > Split.
b. Select the surface as splitting element.
c. Click OK.

6. Thicken the Knob surface
� Apply thickness to the surface as shown.

a. Select Insert > Surface-Based Feature > 
Thick Surface.

b. Select Surface.1 as splitting element.
c. Click OK.

5

6
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Exercise 6A (4/4)

7. Fillet  the sharp edges of the knob part.
� Edge fillet the inner edges. 

a. Select Edge filet icon.
b. Select the internal edges of the knob as 

shown.
c. Specify 2mm radius.
d. Click OK.

8. Modify the knob surface in the source part
� Modify the draft angle of the knob surface.

a. Double-click on the drafted surface 
(Sweep.1).

b. Modify the draft angle to 22deg.
c. Click OK.

� Update the target part to propagate the changes 
performed in the source part.

Target Part

Source Part

8a

7
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Exercise 6A: Recap

� Create a copy/paste special of one part to 
another using different options.

� Create a multi-model link between the parts.
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Exercise 6B
Recap Exercise

20 min

In this exercise, you will practice how to apply  multi-model links using publication in 
assembly context. You will build the mechanical surfaces using styled surfaces and 
later update the model with modified inputs. Detailed instructions for this exercise are 
provided.

By the end of this exercise you will be able to:

� Create a multi-model link between parts using Publications.

� Publish geometries and rename them to your requirements.
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Exercise 6B (1/4)

1. Open the given part consisting of the Styled surfaces for model of the watch in the          
Generative Shape Design Workbench.
a. Browse through the files and open the model

‘Wrist_Watch_Styled_Data_Version_01.CATPart
b. In Tools > Options > Infrastructure > Part Infrastructure > General. 

Select the boxes shown below.

2. Study the model. Publish the styled surfaces and name the published elements.
a. Select Tools > Publication.
b. Select Sub-division Surface. 4. the surface appears

in the Publication box.
c. Rename the Publication as End_Profile
d. Select the other surfaces and rename them

as shown in the picture.
e. Click OK.

Key_ Profile

Diamond

Lower_ Profile

End _Profile

Main_ Body
Dial

Key
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3. Create a new assembly file (CATProduct).
a. Select Start >Mechanical Design > Assembly Design.
b. Rename the Product as ‘Wrist _ Watch’.

4. Insert the styled data part into the assembly
a. Insert existing part ‘ Wrist_ Watch 

_styled_data_Version_01.CATPart’ in the assembly.

5. Insert a new part into the assembly.
a. You will build the mechanical surface into the new part.
b. Rename it as Wrist_ Watch_ Surfaces (Mechanical_ 

Surface).

3

Exercise 6B (2/4)

4

5
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Exercise 6B (3/4)

6a

6b

6c

6d

Observations: You will observe that, when published elements 
are selected to create mechanical surfaces, a contextual link is
created between two parts and a geometrical set named 
‘External References’ is created, containing linked surfaces.

6. Create mechanical surfaces using published elements 
into the part ‘Wrist_Watch_Surface’.
a. Trim the Main body by End_ Profile, Lower_ Profile, Key 

_Profile and Dial surfaces.
b. Split the resultant surface using XY plane.
c. Fillet the edges with 0.5mm radius.
d. Symmetry the surface along XY plane.
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Exercise 6B (4/4)

7a
7. Replace the part containing styled data with its new version.

a. Ensure that the new version of styled data has similar set of 
published elements and the same nomenclature.

b. Replace the part ‘Wrist_Watch_Styled_Data_Version_01.CATPart’
with ‘Wrist_Watch_Styled_Data_Version_02.CATPart’.

c. Update the CATProduct.
d. The model gets updated reflecting the new changes in Version_02 

data. 7b

7c

7d
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Exercise 6B: Recap

� Study the styled surface data of a ‘wrist 
watch’ model.

� Publish the geometries which are referred to 
build mechanical surfaces.

� Build the mechanical surfaces in an 
assembly context using published elements.

� Replace the input data with its new version 
and update the model.
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Case Study: Multi-Model Environment with 
SurfacesRecap Exercise

20 min

In this exercise, you will practice how to apply multi-model link using external references
in the assembly context. You will understand the merits of using publication in an 
multi-model environment.

Using the techniques you have learned in this lesson and previous exercises, create 
the model without detailed instruction.

� Build the top part with the help of the lower half of the camera
without using Publication.

� Replace the bottom (referenced part) by its variant part which 
has a different shape.

� Reroute the links in order to update the model with new 
variants.

� Publish the required surfaces of reference bottom half of the 
camera case.

� Build the top part again using the published surfaces.
� Replace the bottom (referenced part) by its variant part.
� Update the model. You will be able to update without re-

routing the links.
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Do It Yourself: Multi-Model Environment with Surfaces (1/4)

1. Open the Assembly of ‘Web cam’.
a. Browse through the files and open the model 

‘Webcam_start.CATProduct.
b. Select Tools>Options>Infrastructure>Part 

Infrastructure> General and select the options 
in the  External Reference. 

2. Create a new part named ‘Top_Part’
a. Position it on an inferior body by creating 

coincident constraints between xy, yz and zx 
planes.

2a
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Do It Yourself: Multi-Model Environment with Surfaces (2/4)

3. Design the cover in context with ‘Inferior_Body’.
a. Create a 360deg revolve using ‘External Profile’

Sketch of ‘Inferior Body’. Use X direction as the 
revolution axis. 
(Observe that after selecting of the sketch from 
‘Inferior Body’ an External Reference Geometrical 
Set is formed in ‘Top_Part’ ).

b. Split the revolute surface using xy plane.
c. Project ‘Sketch.2’ of  ‘Inferior Body’ on revolved 

surface along the X direction.
d. Split the revolute surface with a projected curve.
e. Thicken the surface by 2mm towards the inside as 

shown.
f. Save the product
g. Open the Spherical_Body_Unpublished.CATPart.

4. Replace the ‘Inferior Body’ with ‘Spherical_ 
Body_Unpublished’ and update the product. 

Notice that some of the assembly constraints are broken. An error is displayed. 
These are the constraints that were pointing to the ‘Inferior_body’.

4

3a

3e
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Do It Yourself: Multi-Model Environment with Surfaces (3/4)

5. Close the product without saving the 
modifications.

6. Reopen the Web Cam assembly 
Webcam_start.CATProduct and publish the 
geometries of Inferior Body, which are referred to 
build the ‘Top_Part’.

7. Rename the product as 
Webcam_with_publications.CATProduct.

8. Rebuild the ‘Top_Part’ using the published 
elements of ‘Inferior Body’.

a. Insert the new part and follow the same process 
used in step 3, but this time use published 
elements of  ’Inferior Body’.

b. Recreate the constraints that need to be connected 
to newly published elements.

c. Save the modified files through Save Management.

6

8
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Do It Yourself: Multi-Model Environment with Surfaces (4/4)

9. Open Spherical_Body_Published.CATPart and check that it contains publication 
with exactly the same names as in ‘Inferior Body'. If not, rename the publications of 
‘Inferior Body’ and save the product again.

10. Replace the ‘Inferior Body’ by ‘Spherical_Body_Published’.

11. Update the product.

Observations: Notice that this time the geometry of ‘Top_Part’ has adapted to spherical shape 
of a new inferior body: the external reference of the Top_Part has been automatically 
reconnected to the published elements of replacing part.

Also notice that the axis of the Support is coincident with the axis of the Inferior Body. The 
constraints have automatically reconnected due to Publication.
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Case Study: Multi-Model Environment with Surfaces Recap

� Build the top part using the lower half of the 
camera without applying Publication.

� Replace the bottom (referenced part) by its 
variant part which has a different shape.

� Reroute the links in order to update the 
model with new variants.

� Publish the required surfaces of reference 
bottom half of the camera case.

� Build the top part again using the published 
surfaces.

� Replace the bottom (referenced part) by is 
variant part.

� Update the model. You will be able to update 
without re-routing the links.


